Android Studio 问题

Android 跑跑 9个月前 (04-22) 224次浏览 2个评论 扫描二维码

一、运行app时发生错误

Android Studio版本2.3.1

Error running app: Instant Run requires 'Tools | Android | Enable ADB integration' to be enabled.

1、原因

因为2.0之后的android studio开始支持instant run(即时运行),通俗的说它可以让你改了代码后,点击即时运行,很快的就可以呈现出我们修改后的代码效果。然后他需要sdk和gradle的支持,而你本地刚好这些条件不符合,所以它才提示。

2、解决办法

(1):开启及时运行,依次点击:Tools–>Android–>点击Enable ADB Integration,将其所对应项前面的对勾勾选上。
Error running app: Instant Run requires 'Tools | Android | Enable ADB integration' to be enabled.
(2):依次点击,Setting->Build,Execution,Deployment->Instant Run。将所有项前面的对勾勾选上。
Error running app: Instant Run requires 'Tools | Android | Enable ADB integration' to be enabled.
(3):修改build.gradle(Project那个),将gradle版本更改至2.0.0以上版本。旧版本project gradle不支持的Instant Run版本。

classpath 'com.android.tools.build:gradle:2.1.3'

3、补充一下ADB

ADB是android sdk里的一个工具,用这个工具可以直接操作管理android模拟器或者真实的andriod设备(如G1手机). 它的主要功能有: * 运行设备的shell(命令行) * 管理模拟器或设备的端口映射 * 计算机和设备之间上传/下载文件 * 将本地apk软件安装至模拟器或android设备 ADB是一个客户端-服务器端程序,其中客户端是你用来操作的电脑,服务器端是android设备。


跑跑博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:Android Studio 问题
喜欢 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(2)个小伙伴在吐槽
  1. 开始搞Android开发了?
    ghostsf2017-04-25 13:19 回复